Bug #1011

GUI crashes at wrong formfactor parameters

Added by ganeva about 5 years ago. Updated almost 5 years ago.

Status:ArchivedStart date:13 Mar 2015
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 26

Description

How to reproduce: simulate some sample with formfactor truncated spheroid, go to real-time activity mode and change the formfactor geometry until the BornAgain will crash due to the assetrion failure:

---
Application Specific Information:
Assertion failed: (m_height <= 2.*m_radius*m_height_flattening), function FormFactorTruncatedSpheroid, file /Users/pospelov/development/BornAgain/source/Core/FormFactors/src/FormFactorTruncatedSpheroid.cpp, line 28.
---

To my opinion, GUI must produce the error message and let user to change the formfactor parameters.

History

#1 Updated by ganeva about 5 years ago

  • Description updated (diff)

#2 Updated by pospelov about 5 years ago

  • Status changed from New to Sprint
  • Assignee set to pospelov
  • Target version set to Sprint 26

#3 Updated by pospelov about 5 years ago

  • Status changed from Sprint to Resolved

#4 Updated by pospelov almost 5 years ago

  • Status changed from Resolved to Archived

Also available in: Atom PDF