Bug #1066

Model lost after unsuccessful load

Added by a.glavic over 5 years ago. Updated over 5 years ago.

Status:ArchivedStart date:08 May 2015
Priority:HighDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 27

Description

After trying to load the attached model there is an error in the instrument parameters that breaks the load process.
The model seems to be loaded fine but when answering OK to the error message the model is gone.

Removing the jobs from the model makes it loadable again.

This was the error message:
Failed to load the project '{Folder}/VR8_2_0.pro'
Exception was thrown with the error message 'ConstKBinAxis::ConstKBinAxis() -> Error. start >= end is not allowed.'

The behavior might be changed to ignore errors when loading a model and replace unvalid parameters with there default.

BornAgain version 1.1.0, compiled on Kubuntu 14.10

  • Take care also ProjectDocument::loadOutputData() which has to warn user in the case of unsuccessful load

VR8_2_0.pro - File with issue (107 KB) a.glavic, 08 May 2015 19:37

History

#1 Updated by a.glavic over 5 years ago

  • Priority changed from Low to High

#2 Updated by herck over 5 years ago

  • Status changed from New to Backlog

#3 Updated by pospelov over 5 years ago

  • Status changed from Backlog to Sprint
  • Target version set to Sprint 27

#4 Updated by pospelov over 5 years ago

  • Description updated (diff)

#5 Updated by pospelov over 5 years ago

  • Assignee set to pospelov

#6 Updated by pospelov over 5 years ago

  • Status changed from Sprint to Resolved

Can't reproduce same behaviour, but I have already fixed bug with missed *.int files, hopefully it helped for this one too.

#7 Updated by pospelov over 5 years ago

  • Status changed from Resolved to Archived

Also available in: Atom PDF