Bug #1085

Fix crash of GUI while trying to save the project under the name containing special characters

Added by pospelov over 5 years ago. Updated over 5 years ago.

Status:ArchivedStart date:13 May 2015
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 27

Description

Request from Marvin Berlinghof

Today I experienced some crashes (including file losses) of the BornAgain GUI (1.1.0) with the same error massage in the shell:
ProjectManager::closeProject() -> XXX/home/path/PS_PEO_170215_I_v110/PS_PEO_170215_I_v110.pro
OutputDataWriter::writeOutputData() -> Error. Can't open file '/home/marvin/path/PS_PEO_170215_I_v110/data_H=60+/-10_0.int' for writing.
terminate called after throwing an instance of 'Exceptions::FileNotIsOpenException'
what(): OutputDataWriter::writeOutputData() -> Error. Can't open file '/home/marvin/path/PS_PEO_170215_I_v110/data_H=60+/-10_0.int' for writing.
Aborted (core dumped)

What I did: I was looking at a job and then wanted to look at data_H=60+/-10_0.int and than BornAgain crashed. This makes sense, because the file is not existing. I don't know why, because I never deleted it. (Probably using "/" in a job name was not my best idea...)

By the way I have another job, called H=30+/-15 which I can look at w/o any crash. But I can't find a file named data_H=30+/-15_0.int in my project folder. So very weird.

Moreover, I had a similar problem when I wanted to look at a job called "delta_si=9.563", but then bornagain crashed. The error massage was:
ProjectManager::closeProject() -> XXX/home/marvin/path/I/PS_PEO_170215_I_v110/PS_PEO_170215_I_v110.pro
Segmentation fault (core dumped)

These problems are reproducible.

History

#1 Updated by pospelov over 5 years ago

  • Description updated (diff)
  • Assignee set to pospelov

#2 Updated by pospelov over 5 years ago

  • Status changed from Sprint to Resolved

#3 Updated by pospelov over 5 years ago

  • Status changed from Resolved to Archived

Also available in: Atom PDF