Bug #1157

Qt dependency is not mentioned in INSTALL

Added by sbusch over 5 years ago. Updated about 5 years ago.

Status:ArchivedStart date:10 Aug 2015
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 29

Description

git clone git://apps.jcns.fz-juelich.de/BornAgain.git
cd BornAgain/
mkdir build_dir
cd build_dir
cmake .. -DCMAKE_INSTALL_PREFIX=/usr/local/share/

-- The C compiler identification is GNU 4.8.4
-- The CXX compiler identification is GNU 4.8.4
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Build in version of Eigen3 will be used
-- Found fftw3 includes at /usr/include
-- Found fftw3 library at /usr/lib/x86_64-linux-gnu/libfftw3.so
-- Boost version: 1.54.0
-- Found the following Boost libraries:
-- date_time
-- chrono
-- program_options
-- iostreams
-- system
-- filesystem
-- regex
-- thread
-- python
-- Boost_INCLUDE_DIRS: /usr/include
-- Boost_LIBRARY_DIRS: /usr/lib/x86_64-linux-gnu
-- Boost_LIBRARIES: /usr/lib/x86_64-linux-gnu/libboost_date_time.so;/usr/lib/x86_64-linux-gnu/libboost_chrono.so;/usr/lib/x86_64-linux-gnu/libboost_program_options.so;/usr/lib/x86_64-linux-gnu/libboost_iostreams.so;/usr/lib/x86_64-linux-gnu/libboost_system.so;/usr/lib/x86_64-linux-gnu/libboost_filesystem.so;/usr/lib/x86_64-linux-gnu/libboost_regex.so;/usr/lib/x86_64-linux-gnu/libboost_thread.so;/usr/lib/x86_64-linux-gnu/libboost_python.so;/usr/lib/x86_64-linux-gnu/libpthread.so
-- Found GSL version 1.16, GSL_INCLUDE_DIR=/usr/include GSL_LIBRARIES=-L/usr/lib lgsl -lgslcblas -lm
-
Found PythonInterp: /usr/bin/python2.7 (found suitable version "2.7.6", minimum required is "2.7")
-- --> PYTHON_VERSION_STRING: 2.7.6, PYTHON_EXECUTABLE:/usr/bin/python2.7
-- Found PythonLibs: /usr/lib/x86_64-linux-gnu/libpython2.7.so (found suitable version "2.7.6", minimum required is "2.7")
-- --> PYTHON_LIBRARIES: /usr/lib/x86_64-linux-gnu/libpython2.7.so, PYTHON_INCLUDE_DIRS:/usr/include/python2.7;/usr/include/x86_64-linux-gnu/python2.7 PYTHONLIBS_VERSION_STRING:2.7.6
-- --> Validating Python installation corresponding to the interpreter /usr/bin/python2.7
-- ----> ALT_PYTHON_PREFIX:/usr
-- ----> ALT_PYTHON_INCLUDE_DIRS:/usr/include/python2.7
-- ----> ALT_PYTHON_SITE_PACKAGES:/usr/lib/python2.7/dist-packages
-- ----> ALT_PYTHON_MODULE_EXTENSION:.so
-- ----> ALT_PYTHON_IS_DEBUG:0
-- ----> ALT_PYTHON_SIZEOF_VOID_P:8
-- ----> ALT_PYTHON_LIBRARY_SUFFIX:2.7
-- ----> Python interpreter reports include directory (see ALT_PYTHON_INCLUDE_DIRS) which differs from what we have learned before (see PYTHON_INCLUDE_DIRS).
-- ----> Setting PYTHON_INCLUDE_DIRS=/usr/include/python2.7
-- --> Python seems to be OK.
-- --> PYTHON_LIBRARIES: /usr/lib/x86_64-linux-gnu/libpython2.7.so, PYTHON_INCLUDE_DIRS:/usr/include/python2.7 PYTHONLIBS_VERSION_STRING:2.7.6
-- Numpy headers found at /usr/lib/python2.7/dist-packages/numpy/core/include
-- Found GCC. Major version 4, minor version 8
-- CMAKE_BUILD_TYPE: Release
-- Looking for include file pthread.h
-- Looking for include file pthread.h - found
-- Looking for pthread_create
-- Looking for pthread_create - not found
-- Looking for pthread_create in pthreads
-- Looking for pthread_create in pthreads - not found
-- Looking for pthread_create in pthread
-- Looking for pthread_create in pthread - found
-- Found Threads: TRUE
-- Found a 64bit system
-- BornAgain Platform: linux
-- BornAgain Architecture: linuxx8664
-- Build Type: Release
-- Compiler Flags: I/home/sbusch/dev/BornAgain/Core/Tools/inc -include WinDllMacros.h -pipe -m64 -Wall -W -Woverloaded-virtual -fPIC -O2
-
Found PythonInterp: /usr/bin/python2.7 (found version "2.7.6")
-- Configuring BornAgain GUI
CMake Error at GUI/CMakeLists.txt:18 (find_package):
By not providing "FindQt5Designer.cmake" in CMAKE_MODULE_PATH this project
has asked CMake to find a package configuration file provided by
"Qt5Designer", but CMake did not find one.

Could not find a package configuration file provided by "Qt5Designer" with
any of the following names:
Qt5DesignerConfig.cmake
qt5designer-config.cmake
Add the installation prefix of "Qt5Designer" to CMAKE_PREFIX_PATH or set
"Qt5Designer_DIR" to a directory containing one of the above files. If
"Qt5Designer" provides a separate development package or SDK, be sure it
has been installed.

-- Configuring incomplete, errors occurred!
See also "/home/sbusch/dev/BornAgain/build_dir/CMakeFiles/CMakeOutput.log".
See also "/home/sbusch/dev/BornAgain/build_dir/CMakeFiles/CMakeError.log".

CMakeError.log Magnifier (3.03 KB) sbusch, 10 Aug 2015 13:10

CMakeOutput.log Magnifier (27.2 KB) sbusch, 10 Aug 2015 13:10

History

#1 Updated by sbusch over 5 years ago

My mistake... I don't think I have Qt installed. So I guess this report reduces to "Qt dependency is not mentioned in INSTALL"...

#2 Updated by herck over 5 years ago

  • Subject changed from Problem compiling version 1.3.0: can't find Qt5DesignerConfig.cmake to Qt dependency is not mentioned in INSTALL
  • Status changed from New to Sprint
  • Target version set to Sprint 29

#3 Updated by pospelov about 5 years ago

  • Assignee set to pospelov

#4 Updated by pospelov about 5 years ago

  • Status changed from Sprint to Resolved

#5 Updated by pospelov about 5 years ago

  • Status changed from Resolved to Archived

Also available in: Atom PDF