Feature #1256

Feature #418: === Configuration & Build ===

Feature #1363: == Unix build ==

CMake should notify the user during the build if there is already previous version of BornAgain installed on the system

Added by pospelov almost 5 years ago. Updated about 3 years ago.

Status:RejectedStart date:09 Dec 2015
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

The problem arise when the user tries to compile BornAgain and then runs 'make check' command. If BornAgain was already installed on the system (i.e. appears in LD_LIBRARY_PATH and PYTHONPATH), then "make check" step fails. We have this issue explained in troubleshooting section, but this is not enough. There were few reports on that already.

It should be possible. We can retrieve environment variable and warn the user.

History

#1 Updated by wuttke over 4 years ago

  • Parent task set to #418

#2 Updated by wuttke over 4 years ago

  • Parent task changed from #418 to #1363

it's Unix specific, right?

#3 Updated by pospelov about 3 years ago

  • Status changed from Backlog to Rejected

Rejected as duplicate of #1751

Also available in: Atom PDF