Refactoring #1264

Refactor ParameterizedItem's different naming schemes

Added by herck over 4 years ago. Updated about 4 years ago.

Status:RejectedStart date:22 Dec 2015
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Sprint 30

Description

For the moment, ParameterizedItem has a property "Name", a QString modelType() and a QString displayName().
Since displayName() resolves ambiguities between children of the same type (by giving an extra index), this name should be displayed in the GUI (preferably using the property mechanism that automatically updates the corresponding views).

Is a user customized property "Name" still relevant or can we get rid of it?

History

#1 Updated by herck about 4 years ago

  • Status changed from Sprint to Rejected

Duplicate of #1270

Also available in: Atom PDF