Bug #1293

bold math symbols broken under Texlive2015

Added by wuttke over 4 years ago. Updated 2 days ago.

Status:ResolvedStart date:02 Feb 2016
Priority:LowDue date:
Assignee:wuttke% Done:

80%

Category:-
Target version:-

Description

In our manual, we are using the unicode-math package under xelatex to get ISO-style bold italic math symbols. This worked smoothly until Texlive2014 (as per Debian/jessie), but is broken under Texlive2015 (Debian/stretch).

Here is a minimal example to reproduce the bug:

\documentclass{minimal}
\usepackage[bold-style=ISO]{unicode-math}
\setmathfont{xits-math.otf}
\renewcommand{\v}[1]{\ensuremath{\mathbf{#1}}}
\newcommand{\Nabla}{\v{\nabla}}
\begin{document}
Is this $\Nabla$ a nabla? Is this vector $\v{r}$ slanted?
\end{document}

History

#1 Updated by wuttke over 4 years ago

  • Description updated (diff)

#2 Updated by wuttke over 4 years ago

  • Parent task changed from #1261 to #966

#3 Updated by wuttke over 4 years ago

  • Priority changed from Urgent to High

#4 Updated by herck over 4 years ago

  • Target version set to Sprint 30

#5 Updated by herck over 4 years ago

  • Assignee set to herck

#6 Updated by herck over 4 years ago

  • Status changed from Sprint to Backlog
  • Assignee deleted (herck)

#7 Updated by wuttke over 4 years ago

  • Target version deleted (Sprint 30)

#8 Updated by wuttke over 4 years ago

Reported as Debian bug 815467.

#9 Updated by wuttke over 4 years ago

#10 Updated by wuttke over 4 years ago

  • Status changed from Backlog to Sprint
  • Assignee set to wuttke
  • Target version set to Sprint 31
  • % Done changed from 0 to 80

Solution at https://github.com/wspr/unicode-math/issues/340.
Implemented in b420ec8.
TODO: test under unicode-math-0.8

#11 Updated by wuttke over 4 years ago

  • Status changed from Sprint to Backlog
  • Target version deleted (Sprint 31)

I'll finish this when I'm back home. Not needed for sprint31 though.

#12 Updated by wuttke over 4 years ago

  • Status changed from Backlog to Sprint

#13 Updated by wuttke over 4 years ago

  • Status changed from Sprint to Resolved

Works for me. No need right now to test with older unicode-math. And there is even a chance that it would work.

#14 Updated by wuttke over 4 years ago

  • Priority changed from High to Low

#15 Updated by wuttke 2 days ago

  • Parent task deleted (#966)

Also available in: Atom PDF