Refactoring #1295

Feature #1290: === Core: framework ===

remove 'inc/ and 'src/' directory level

Added by wuttke about 4 years ago. Updated over 3 years ago.

Status:ArchivedStart date:02 Feb 2016
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Sprint 31

Description

For IDE user it doesn't matter, but for command-line folk this extra directory level is annoying.

Furthermore, current usage is not consistent (Core/StandardSamples has no inc/ and src/ subdirectories).

History

#1 Updated by wuttke about 4 years ago

  • Description updated (diff)

#2 Updated by pospelov about 4 years ago

  • Tracker changed from Bug to Refactoring

I have taken the liberty to change tracker category from "Bug" to "Refactoring".

  • to have smaller number of "still open bugs" in Redmine/BornAgain/Overview section
  • and because it is not a bug, and even not a feature, but rather some personal choice made in the past
    A software bug is an error, flaw, failure or fault in a computer program or system that causes it to produce an incorrect or unexpected result, or to behave in unintended ways. Most bugs arise from mistakes and errors made by people in either a program's source code or its design, or in frameworks and operating systems used by such programs, and a few are caused by compilers producing incorrect code. A program that contains a large number of bugs, and/or bugs that seriously interfere with its functionality, is said to be buggy or defective. Reports detailing bugs in a program are commonly known as bug reports, defect reports, fault reports, problem reports, trouble reports and so forth.
    

And yes, I support the idea, let's refactor directory structure

#3 Updated by pospelov about 4 years ago

  • Status changed from New to Sprint
  • Target version set to Sprint 31

#4 Updated by jmfisher almost 4 years ago

  • Status changed from Sprint to Resolved

#5 Updated by jmfisher almost 4 years ago

inc/ and src/ directory level removed from App/, Core/, and Fit/

#6 Updated by herck over 3 years ago

  • Status changed from Resolved to Archived

Also available in: Atom PDF