Bug #1515

Feature #964: === GUI ===

GUI: error in determination of size of imported tiff file causes crash of fitting

Added by ganeva over 3 years ago. Updated over 3 years ago.

Status:RejectedStart date:15 Jul 2016
Priority:HighDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint32

Description

How to reproduce:
1. Start BornAgain (1.6.1, hotfix)
2. Instrument-> Set nbins=981 (phi) and nbins=1043 (alpha)
3. Sample -> take some predefined sample (Cylinders and prisms, for example)
4. Import -> load some GALAXI tiff file
5. Simulation -> set sample and real data
6. Click 'run simulation' => the error message (see screenshot) will appear
7. Instrument -> Set nbins=981 (phi) and nbins=981 (alpha)
8. Simulation -> Run Simulation
9. Jobs -> Change to 'Fitting activity' in the bottom right corner

BornAgain will crash with the message:

Application Specific Information:
abort() called
terminating with uncaught exception of type Exceptions::RuntimeErrorException: IntensityDataFunctions::createRelativeDifferenceData() -> Error. Different dimensions of data and reference.

Screen Shot 2016-07-15 at 09.18.57.png - Error message on click of 'Run Simulation' (28.1 KB) ganeva, 15 Jul 2016 09:22

Screen Shot 2016-07-15 at 09.26.54.png - Import tiff file (dimension are correct) (38.7 KB) ganeva, 15 Jul 2016 09:27

scan_pchi_detz_mg5_A_1440s.1.tif - some GALAXI tiff file (3.91 MB) ganeva, 15 Jul 2016 09:37

History

#1 Updated by ganeva over 3 years ago

  • Description updated (diff)

#2 Updated by ganeva over 3 years ago

  • Description updated (diff)

#3 Updated by ganeva over 3 years ago

  • Priority changed from Normal to High

#4 Updated by wuttke over 3 years ago

  • Parent task set to #964

#5 Updated by pospelov over 3 years ago

  • Status changed from New to Sprint
  • Target version set to Sprint32

#6 Updated by herck over 3 years ago

  • Assignee set to herck

#7 Updated by herck over 3 years ago

  • Status changed from Sprint to Rejected

Can't reproduce anymore (after massive refactoring of real data import functionality)

Also available in: Atom PDF