Documentation #1519

Feature #418: === Configuration & Build ===

Linking failure of Ubuntu with Python installed via Anaconda bundle

Added by pospelov almost 4 years ago. Updated over 2 years ago.

Status:RejectedStart date:18 Jul 2016
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Found an Ubuntu, there in addition to system Python there are two Anaconda's Python2 and Python3 bundles, all in PATH/LD_LIBRARY_PATH.

The problem was that Anaconda distribution also has include directory with boost headers in it.

Our cmake machinery, seems to
  • either take boost headers from Anaconda/include, boost libraries from the system /usr/lib
  • or vice verse

and then 'make' fails on linking stage with lots of boost names not found.

  • The issue is easy to resolve, if one convince the user not to build against Anaconda
    1) Use cmake with -DCMAKE_PREFIX_PATH=/usr/ during cmake configuration, 
    2) remove Anaconda from LD_LIBRARY_PATH
    
  • However, if user wants keep using Python from Anaconda, while having other dependencies from /usr, the solution is more complicated
    Use cmake with -DPYTHON_LIBRARY=$ANACONDA/lib/libpython2.7.dylib -DPYTHON_EXECUTABLE=$ANACONDA/bin/python2.7 -DCMAKE_PREFIX_PATH=/usr
    
Within this item
  • Describe the case in troubleshooting section.

History

#1 Updated by wuttke almost 4 years ago

  • Parent task set to #418

#2 Updated by wuttke over 3 years ago

  • Tracker changed from Bug to Documentation

Not a bug on our side.

We should not even attempt to hard code ways to deal with such badly configured systems.

At most, add a paragraph to the installation instructions.
Or close this issue for good.

#3 Updated by pospelov over 2 years ago

  • Status changed from Backlog to Rejected

Rejected, see #1823

Also available in: Atom PDF