Refactoring #1604

Feature #1290: === Core: framework ===

move expected inaccuracy (m_variability) out of class OutputData

Added by pospelov about 1 year ago. Updated 10 months ago.

Status:ResolvedStart date:09 Sep 2016
Priority:LowDue date:
Assignee:-% Done:

0%

Category:-
Target version:Sprint 33

Description

To my opinion, the OutputData class is our key data structure related to the storage of binned data. It should not contain functionality related to the testing. If more functionality is required, it can be implemented in a separate class.


Related issues

Related to BornAgain - Testing #1609: Clarify relation between PyPersistence tests and tutorial examples Resolved 27 Sep 2016

History

#1 Updated by wuttke about 1 year ago

  • Tracker changed from Bug to Refactoring
  • Priority changed from Normal to Low

Agree that current solution is unsatisfactory. It's not a bug though.

Set to low priority because possibly we need just some time to discover an elegant solution.

#2 Updated by wuttke about 1 year ago

  • Subject changed from Remove OutputData::setVariability and ::getVariability to move expected inaccuracy (m_variability) out of class OutputData

#3 Updated by wuttke 12 months ago

  • Parent task set to #1606

to be investigated in the context of examples / functional tests

#4 Updated by wuttke 10 months ago

  • Parent task changed from #1606 to #1290

#5 Updated by pospelov 10 months ago

  • Status changed from Backlog to Sprint
  • Target version set to Sprint 33

#6 Updated by wuttke 10 months ago

  • Related to Testing #1609: Clarify relation between PyPersistence tests and tutorial examples added

#7 Updated by wuttke 10 months ago

  • Status changed from Sprint to Resolved

Resolved in 5baab.
For standard simulations, the expected inaccuracy is hard-coded in StandardSimulationsRegistry.cpp as before.
For Python example perstistence tests, the inaccuracy is now hard-coded in PyCore/persistence/CMakeLists.txt.
Therefore the "reproducibility" entry could be removed from all reference data.

Also available in: Atom PDF