Bug #1613

detector.setPerpendicularToReflectedBeam moves detector in the case of the beam divergence

Added by ganeva over 3 years ago. Updated over 3 years ago.

Status:RejectedStart date:06 Oct 2016
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint32

Description

If detector is set to be perpendicular to the reflected beam, it will be moved during simulation if the beam divergence is present. As a result, strange image will be produced.

The detector should be fixed independent on the beam divergence.

History

#1 Updated by herck over 3 years ago

  • Status changed from New to Sprint
  • Target version set to Sprint32

#2 Updated by herck over 3 years ago

  • Assignee set to herck

#3 Updated by herck over 3 years ago

  • Status changed from Sprint to Rejected

Cannot reproduce. At least in develop branch, this issue is solved.

Also available in: Atom PDF