Bug #1639

Feature #964: === GUI ===

GUI: crash if fitting parameter removed

Added by ganeva about 1 year ago. Updated 12 months ago.

Status:ResolvedStart date:14 Nov 2016
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint 33

Description

To reproduce:
create a project, load the experimental data. Add fit parameter, then remove it (see screenshot). Run fit. BornAgain will crash.

Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called
terminating with uncaught exception of type GUIHelpers::Error: t exception of type GUIHelpers::Error: ParameterContainer() -> Error. Wrong size of value vector.

Global Trace Buffer (reverse chronological seconds):
51.266350    libextension.dylib            0x00007fff983de533 tearing down extension request for pid 33344

Screen Shot 2016-11-14 at 17.43.01.png - Remove fit parameter (26.6 KB) ganeva, 14 Nov 2016 17:54

crash.txt Magnifier - full crash report (69.4 KB) ganeva, 14 Nov 2016 17:55

History

#1 Updated by pospelov about 1 year ago

  • Status changed from New to Sprint
  • Target version set to Sprint 33

Removal of parameter link from fit parameter, while keeping fit parameter alive for following re-use, is intended behavior. The crash is not, of course, and will be fixed during the next release.

#2 Updated by wuttke about 1 year ago

  • Parent task set to #964

#3 Updated by herck 12 months ago

  • Assignee set to herck

#4 Updated by herck 12 months ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF