Documentation #1823

Revise current list of Redmine issues

Added by pospelov 7 months ago. Updated 4 months ago.

Status:ResolvedStart date:30 Jun 2017
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 35

Description

Consider cleaning up of our Redmine

  • to make the development more agile
  • to get rid from very minor issues or issues that are non-relevant anymore
  • to use Redmine for support of current work, rather than as a storage of long term ideas, or minor programming suggestions
  • #151 Check with ToyExperiment the influence of numerical error in chi2/residuals on fit stability

Old issue, not important in the context of much bigger "local minima problem".

  • #395 Create rpm package

For whom? Better focus first on BornAgain inclusion on Debian scientific repository.

  • #472 Support Artur and Elisabeth with simulation scripts

?

  • #488 Fix issues encountered by Artur

Some of issues already solved, for others is not clear what was meant.

  • #504 Polarized GISANS on mesocrystals (Disch)

Contact was lost

  • #520 Fix issues encountered by JFM

Revise and make dedicated issue, if necessary

  • #525 Simulations for oxide layers with magnetization (A.Steffen)

?

  • #532 Check distribution of mesocrystal heights in simulation

Unclear

  • #533 Check distribution of lattice parameters (both isotropic and anisotropic)

Unclear

  • #542 Windows installer: check existence of BornAgain and uninstall it if exists

Valid request, but no sense to try solve if for current NSIS-based installer. We have to move to another type of Windows installer (e.g. qt-installer framework).

  • #548 Provide script to fit mesocrystal data from Python

We have to consider first whether to renew our mesocrystal activity.

  • #550 Simulations of multi layered sample for S. Mattauch

?

  • #606 Restore automatic Doxygen API generation

Should be probably dropped after migration to new statically based documentation site

  • #649 Provide lattice rotation example

Partly solved, partly mixed with other issues (new SimulationBuilder machinery)

  • #650 Provide two cylinders example with two different SLD

Who wants this? We do not have a concept of SLD in materials yet.

  • #652 Flat cylinders with transformation (coherent and uncoherent example)

?

  • #707 Support Thaer Kassar: Hetero-junction thin films

Contact was lost

  • #708 Support Vicky Doan-Nguyen: In-plane lamellar packing of nanorods

Contact was lost

  • #726 Review calculation of R,T coefficients for magnetic case

Is it still relevant?

  • #728 Install BornAgain at the relevant instruments

At Galaxi it is installed.

  • #890 Formfactor restrictions in fitting and distributions

I think, it is already possible via RealLimits applied to parameter distribution.

  • #892 Provide BornAgain support in MacPorts

Very low priority.

  • #899 GUI: create "install libBornAgainCore in Python" widget

Not needed for Windows, for MacOS not sure that it is the best approach.

  • #929 Provide script to read offspecular data from MARIA

Too specific. Context is lost.

  • #967 Support Marvin Berlinghof: provide python example for simulation of Ruderer et al. 2012

Have to renew acquaintance, or drop the issue.

  • #936 Provide script to read GISANS data from MARIA

Context is lost

  • #939 Prepare mesocrystal simulation status report

Too optimistic issue. First we have to re-start mesocrystal activity.

  • #1029 ToF support in OffSpecSimulation

Two years old issue by Artur.

  • #1030 SLD, specular and particle density

Is it not already solved?

  • #1098 Add Python examples Interference2DLatticeSumOfRotated and TriangularRipple to Drupal

Too specific (or have too low priority) in the view of changes in documentation

  • #1139 Py: Provide Simulation class with possibility to set vector of SimulationElements from outside

Partly coincide with other Artur's suggestions. Better to remove issue and wait the subject reappears.

  • #1187 Implement 1D fitting in SpecularSimulation

Too broad.

  • #1199 Consider implementation of partial structure factor

Unclear

  • #1263 Drupal: provide bornagainproject.org site backup

Almost obsolete

  • #1282 Drupal: unique form of persistent page URLs

Almost obsolete

  • #1432 final polish of polyhedral form factor

Is polishing still necessary?

  • #1437 Release requirement: Update example scripts

Part of web site migration. No need for an issue.

  • #1441 Support Anatoly Berezkin

Contact is lost.

  • #1457 Calculate precomputed tables at compile time

Is it still relevant? Can be done in connection with some concrete future refactoring.

  • #1463 possibility to specialize|generalize physical models on the fly

Too broad, no context.

  • #1469 Package Multifit-Suite as separate library

Should be postponed. I'm not sure that quality of our ROOT-based minimization kernel worth extra work. We might discover some better C++ library in the future (e.g. everyone wants Baesyan minimisers, we do not have them).

  • #1476 Find an appropriate path for the BornAgain executable

Too specific while there is more global question (installation directory structure). Suggest to drop unless the future will give us extra motivation.

  • #1480 Buildbot: provide tutorial how to add new build configuration: Windows

Issue is there since a long time. Seems that nobody is actually interested.

  • #1481 Buildbot: provide tutorial how to add new build configuration: MacOS

Issue is there since a long time. Seems that nobody is actually interested.

  • #1491 GUI: improve GUI fitting performance

Still valid, but I would close to not spoil Redmine

  • #1508 GUI JobView: reconsider location of activity view switch

Seems the location is not that bad.

  • #1500 MacOS: provide vagrant test box for El Capitan

Painful issue, and not really necessary.

  • #1509 Version string should be different for executables generated from 'develop', from feature branches, or from 'master'

Not clear, if it is that necessary.

  • #1519 Linking failure of Ubuntu with Python installed via Anaconda bundle

Should be closed. Hard to reproduce, no complains anymore.

  • #1532 clarify relation of PolDWBAMagCylinders2 and StandardSimulations/StandardSimulations.h/cpp to standard Core function tests

Nothing to do. Custom tests will at some point, become the part of standard tests. Or will not.

  • #1537 parametrize Gaussians and Lorentzians by mean and fwhm

Is this really necessary?

  • #1538 AttLimits::isInRange(value) returns true for value==m_lower_limit, and false for value==m_upper_limit

Nothing to do (or too much todo).

  • #1544 require libcerf instead of providing ThirdParty/Fadeeva

If I'm not mistaken, libcerf has to be changed first.

  • #1553 Project (XML) read-in: support old versions by automatic conversion of old to new class and function names

Seems to me, too much burden to support. Better to invest in normal back compatible project file format.

  • #1554 provide script to update Python files upon name changes in BornAgain

Not necessary in the view of python examples machinery. Easy to fix any API manually, rather than support change history.

  • #1567 omit »FormFactor« from particle geometry class names

Duplication of #1766

  • #1570 replace parameter accessor methods getFoo() by getParameterValue("Foo")

Minor issue which will naturally reaper on the next necessary refactoring of RealParameter machinery

  • #1581 get... -> create... if new pointer is returned

No need for dedicated issue.

  • #1596 handle variable instance names differently from fixed class names (=> split INamed)

Not need for extra work here, I think. INamed class name perfectly reflect the purpose - to give names to things.

  • #1598 decide on policy for incomplete ICompositeSample descendant constructors

No issue here, I think.

  • #1599 provide another suite of functional tests: simulate on different grids, and test numeric consistence of results

Too broad issue, use case is required. Refactoring of functional test machinery is absolutely necessary first.

  • #1622 avoid smart pointers in user API

No need for issue

  • #1626 Specular calculation gives weird results below critical angle in presence of top layer absorption

Is it still relevant?

  • #1627 python API kvector_t missing basic operator

We have to remove, there possible usage of kvector_t in Python API. Use lists or numpy arrays instead.

  • #1629 GISASSimulatin setAnalyzerProperties total_transmission default parameter generates Exception

Is it still relevant?

  • #1636 Unexpected wavelength depent intensity Roughness vs. ParticleLayout

Is it still relevant?

  • #1638 Manual: Improve / restore side bar navigation

Is it still relevant?

Is it still relevant?

No need for envelop task

  • #1686 Release procedures and pre-release actions

No need for envelop task

  • #1695 GUI: Implement crash handler, and restoration of state before crash

Partly implemented (autosave), partly very difficult to implement (crash handler) in platform independent way.

  • #1699 functional tests: Improve MinimizerCatalogue::toString

Nobody ever asked for it. Given issue has to be, one day, the part of much bigger polishing of fitting API.

  • #1701 import real-space sample configuration, e.g. from molecular dynamics (morphology file of IsGISAXS)

No user request

  • #1707 refactor LayerStrategyBuilder, DecoratedLayerComputation -> LayoutStrategyBuilder, DecoratedLayoutComputation

Already done, in a sense

  • #1713 light refactoring proposals

Should not be part of issue tracker (I think)

  • #1714 Enhance functionality

No need for envelop task

  • #1715 start sample construction with SlabSample() or FilmSample()

Nice idea to have in mind, but I'm afraid that the perception might change from sub-community to sub-community.

  • #1717 GISASSimulation: setBeamParameters and setDetectorParameters have opposite order of alpha, phi

Will affect everyone in a world. Also depends on personal preferences, some might find the ordering not that important.

  • #1719 Manual: avoid the word "matrix" for embedding, ambient bulk material

May be not for this tracker.

  • #1720 Vacuum() instead of HomogeneousMaterial("Air", 0.0, 0.0)

Issue will naturally reappear as soon as we implement normal material library. For the moment no need to bother.

  • #1721 Scattered intensity should depend on beam size and sample size

Valid reminder, but seems very big and context dependent.

  • #1732 Optimization in innermost loop in RT computation

Partly already done. Further improvements should be based on profiling.

  • #1738 Rename files and classes in Multilayer to resolve ambiguity about "Matrix"

Already done, I guess.

  • #1741 Wavelength/radiatio independent way to define material parameters

We know about it and have similar issues. Need good planing and issue-by-issue implementation. Have to wait for new collaborator.

  • #1748 Consider IParameter storing the data by reference

Why I have suggested it?

  • #1767 array operations for python custom form factor

Idea that flying in the air for a while, but let's wait for user request

  • #1770 support CBF data from A. Nent

Have to be dropped. We must agree on general solution (fabio library, data broker or something else).

issues.csv Magnifier (115 KB) pospelov, 15 Sep 2017 11:10

issues.pdf (917 KB) pospelov, 15 Sep 2017 11:10

History

#1 Updated by pospelov 7 months ago

  • Description updated (diff)

#2 Updated by pospelov 7 months ago

  • Subject changed from Revise current list of Remine issues to Revise current list of Redmine issues
  • Description updated (diff)

#3 Updated by pospelov 4 months ago

  • File issues.csvMagnifier added
  • File issues.pdf added
  • Status changed from Rfc to Sprint
  • Assignee set to pospelov
  • Target version set to Sprint 35

#4 Updated by pospelov 4 months ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF