Bug #1886

Average materials do not work if more than one layout is connected to the layer

Added by ganeva about 3 years ago. Updated about 3 years ago.

Status:RejectedStart date:10 Nov 2017
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint 36

Description

The error message is

libc++abi.dylib: terminating with uncaught exception of type std::runtime_error: MainComputation::getAveragedMultilayer: total volumetric fraction of particles exceeds 1!

To reproduce take some BornAgain example and add the code to use average materials. Than add a particle layout twice (see the attached script).

test.py Magnifier (1.87 KB) ganeva, 10 Nov 2017 12:43

History

#1 Updated by herck about 3 years ago

  • Status changed from New to Sprint
  • Target version set to Sprint 36

#2 Updated by herck about 3 years ago

  • Status changed from Sprint to Rejected
  • Assignee set to herck

This is intended behavior, the total volume of the particles embedded cannot be higher than the volume they're in.

Also available in: Atom PDF