Bug #1914

Lattice::reciprocalLatticeVectorsWithinRadius does not behave as expected

Added by herck about 2 years ago. Updated about 2 years ago.

Status:ResolvedStart date:01 Dec 2017
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint 36

Description

The one-dimensional equivalent of the problem is as follows:
If the input vector is just in between two lattice points and the given radius is just a bit smaller than the lattice vector length, only one point will be returned (although both neighboring lattice points qualify).
See also temporary disabled unit test of Lattice.

History

#1 Updated by herck about 2 years ago

  • Assignee set to herck

#2 Updated by herck about 2 years ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF