Bug #1926

Compilation fails on Windows with Qt 5.10.0

Added by dmitry over 2 years ago. Updated over 2 years ago.

Status:ResolvedStart date:14 Dec 2017
Priority:LowDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 36

Description

With the following message:

[ 54%] Linking CXX shared library ..\..\bin\_libBornAgainGUI.dll
   Creating library BornAgainGUI.lib and object BornAgainGUI.exp
LINK : warning LNK4098: defaultlib 'LIBCMT' conflicts with use of other libs; use /NODEFAULTLIB:library
widgetboxtreewidget.cpp.obj : error LNK2019: unresolved external symbol "__declspec(dllimport) public: class QList<class DomWidget *> __cdecl DomWidget::elementWidget(void)const " (__imp_?elementWidget@DomWidget@@QEBA?AV?$QList@PEAVDomWidget@@@@XZ) referenced in function "public: void __cdecl qdesigner_internal::WidgetBoxTreeWidget::dropWidgets(class QList<class QDesignerDnDItemInterface *> const &)" (?dropWidgets@WidgetBoxTreeWidget@qdesigner_internal@@QEAAXAEBV?$QList@PEAVQDesignerDnDItemInterface@@@@@Z)
..\..\bin\_libBornAgainGUI.dll : fatal error LNK1120: 1 unresolved externals
LINK failed. with 1120

The problem seems to be caused by the declaration of the class DomWidget in GUI\coregui\Views\widgetbox\ui4_p.h:

class QDESIGNER_UILIB_EXPORT DomWidget {...}

In principle, the problem is solved by just replacing the declaration with

class DomWidget {...}

The class is competely header-contained.

A better solution would be just to get rid of this Qt internal completely.

History

#1 Updated by pospelov over 2 years ago

  • Status changed from New to Sprint
  • Assignee set to pospelov
  • Target version set to Sprint 37

#2 Updated by pospelov over 2 years ago

  • Target version changed from Sprint 37 to Sprint 36

#3 Updated by pospelov over 2 years ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF