Bug #1980

GUI: fitting of incident angle

Added by ganeva about 2 years ago. Updated about 2 years ago.

Status:ResolvedStart date:27 Feb 2018
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint 36

Description

fitting if the incident angle is possible, but the fit delivers weird simulation results.

History

#1 Updated by herck about 2 years ago

  • Assignee deleted (herck)

This bug was already present from the introduction of fitting in the GUI (v1.8). It is caused by the misalignment of units in GUI and core (degrees vs radians), which is not handled by the fitting machinery.

A temporary solution could be implemented by translating between degrees and radians in:
FitParameterItem::createFitParameter
FitParameterContainerItem::setValuesInParameterContainer

#2 Updated by herck about 2 years ago

  • Assignee set to herck

#3 Updated by herck about 2 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF