Bug #2009

qwindowsvistatsyle.dll cannot be found under Qt5.9.3 on windows

Added by dmitry over 2 years ago. Updated over 2 years ago.

Status:RejectedStart date:12 Mar 2018
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Sprint 37

Description

Probably, because it is not a separate library until Qt5.10.0.

Output from CPack -C Release:

CPack -C Release
CPack: Create package using NSIS
CPack: Install projects
CPack: - Install project: BornAgain
CPack: - Install component: Applications
CPack: - Install component: Examples
CPack: - Install component: Headers
CPack: - Install component: Libraries
CMake Error at C:/Users/DmitryYurov/Documents/Software/BARelease/GUI/coregui/cmake_install.cmake:83 (file):
file INSTALL cannot find
"C:/Qt/Qt5.9.3/5.9.3/msvc2017_64/plugins/styles/qwindowsvistastyle.dll".
Call Stack (most recent call first):
C:/Users/DmitryYurov/Documents/Software/BARelease/GUI/cmake_install.cmake:33 (include)
C:/Users/DmitryYurov/Documents/Software/BARelease/cmake_install.cmake:46 (include)

CPack Error: Error when generating package: BornAgain

History

#1 Updated by herck over 2 years ago

  • Status changed from Sprint to Rejected

This issue is known. Since we only provide installers for Windows systems, and these are build with Qt5.10, this poses no problem.

#2 Updated by dmitry over 2 years ago

I still will disable this library installation for older Qt versions and add warning for developers.

Also available in: Atom PDF