Refactoring #2031

replace obsolete qt5_use_modules

Added by wuttke about 2 years ago. Updated about 2 years ago.

Status:ResolvedStart date:09 Apr 2018
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint 37

Description

According to https://doc.qt.io/qt-5.10/cmake-manual.html, the macro qt5_use_modules is obsolete. It is currently used in

  • Tests/Functional/GUI/GUIStandardTest/CMakeLists.txt,
  • Tests/Functional/GUI/GUISpecial/CMakeLists.txt,
  • Tests/UnitTests/GUI/CMakeLists.txt.

It should be replaced by target_link_libraries with IMPORTED targets.

History

#1 Updated by herck about 2 years ago

  • Status changed from New to Sprint
  • Assignee set to herck
  • Target version set to Sprint 37

#2 Updated by herck about 2 years ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF