Bug #2034

Formfactor Icosahedron crosses interface boundary

Added by ganeva over 2 years ago. Updated 3 months ago.

Status:RejectedStart date:13 Apr 2018
Priority:HighDue date:
Assignee:wuttke% Done:

0%

Category:-
Target version:-

Description

To reproduce:
1. Take the example RotatedPyramids.py
2. replace line 18 with

pyramid_ff = ba.FormFactorIcosahedron(10.0*nm)

3. Run, see the exception
Exception Type:        EXC_CRASH (SIGABRT)
Exception Codes:       0x0000000000000000, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Application Specific Information:
abort() called
terminating with uncaught exception of type std::runtime_error: Icosahedron::sliceFormFactor error: not implemented!

History

#1 Updated by ganeva over 2 years ago

  • Subject changed from Formfactor Icosahedron rotated around Z crosses interface boundary to Formfactor Icosahedron crosses interface boundary

Icosahedron simulated in DWBA crosses interface boundary even without rotation.

#2 Updated by wuttke 3 months ago

  • Assignee set to wuttke
  • Priority changed from Normal to High

#3 Updated by wuttke 3 months ago

  • Status changed from New to Rejected

cannot reproduce

Also available in: Atom PDF