Feature #2046

Provide defense against running Python script with wrong version of Python interpreter

Added by pospelov over 1 year ago. Updated 7 months ago.

Status:BacklogStart date:03 May 2018
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

Common mistake from the user:

  • compile BornAgain against Python3
  • run Python example using default system interpreter python->python2.7

It should be possible to propagate expected Python number in our init.py and then warn the user, if actual interpreter differs.

History

#1 Updated by wuttke 7 months ago

  • Subject changed from Provide defence against running Python script with wrong version of Python interpreter to Provide defense against running Python script with wrong version of Python interpreter
  • Assignee set to wuttke

#2 Updated by wuttke 7 months ago

  • Status changed from Backlog to Sprint

#3 Updated by wuttke 7 months ago

  • Status changed from Sprint to Backlog
  • Assignee deleted (wuttke)

Also available in: Atom PDF