Bug #2139

Inconsistent impact of Euler rotation on simulation/3D view

Added by pospelov about 2 years ago. Updated about 2 years ago.

Status:ResolvedStart date:06 Sep 2018
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:Sprint 38

Description

I would like to simulate cylinders lying on substrate and rotated by 45 around Z of the sample. For that I have to first Y-rotate them by 90 deg,
and then Z-rotate by 45 deg. Since in GUI there is no consecutive rotations, one have to use Euler rotation.
Parameters of Euler rotation will be alpha=45deg, beta=90deg (if I'm not mistaken).

Constructed sample and it's 3D view is shown on screenshot.

The problem is that simulation doesn't depend on alpha angle, while 3D view correctly shows that cylinders are rotated around vertical axis.

Possible reasons

  • I misunderstand Euler rotation's parameters (and so 3DView too)
  • Alpha angle of Euler rotation is not propagated to the Core (but Python simulation is ocnsistent with GUI)
  • Euler rotation is wrong in Core.
  • I misunderstand scattering from lying cylinders.

Screenshot_20180906_020010.png (380 KB) pospelov, 06 Sep 2018 02:48

History

#1 Updated by herck about 2 years ago

  • Assignee set to herck

#2 Updated by herck about 2 years ago

  • Status changed from Sprint to Resolved

The reason was a wrong translation between Euler angles and the corresponding rotation matrices

Also available in: Atom PDF