Bug #2153

3D view crashes on rotated 1D interference function

Added by pospelov about 2 years ago. Updated about 2 years ago.

Status:RejectedStart date:17 Sep 2018
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 38

Description

  • Create sample as on screenshot.

1D interference function and box, default parameters

  • Open 3D view and look at MultiLayer
  • Lock the view
  • Go to properties of 1D interference function and change rotation angle Xi to 45 degrees
  • GUI will crash on Xi change

Screenshot_20180917_172956.png (307 KB) pospelov, 17 Sep 2018 17:31

History

#1 Updated by pospelov about 2 years ago

  • Assignee set to pospelov

#2 Updated by pospelov about 2 years ago

  • Status changed from Sprint to Rejected

Can't reproduce on Mac and Linux on latest nightly. Valgrind shows everything OK. Must be cured already on the way from Release to current nightly.

Also available in: Atom PDF