Bug #2236

GUI: Fitting failure on some minimization algorithms

Added by dmitry 12 months ago. Updated 11 months ago.

Status:ResolvedStart date:30 Nov 2018
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 39

Description

To reproduce:

Create simulation with default GISAS instrument and default "Cylinders and prisms" sample.
Save simulation result, load it and set up fitting.
Try to fit beam intensity with e.g. Fumili algorithm chosen.

You will see a failure message (see screenshot)

Fails on the following algorithms:

Minuit2 - Fumili
GSL Levenberg-Marquardt
GSL MultiMin (only if start value is out of (min,max) range)

Screenshot_20181130_123215.png - Failure message (724 KB) dmitry, 30 Nov 2018 12:32

History

#1 Updated by dmitry 12 months ago

  • Subject changed from GUI: Fitting failure with Fumili algorithm to GUI: Fitting failure on some minimization algorithms
  • Description updated (diff)
  • Status changed from Backlog to Sprint
  • Target version set to Sprint 39

#2 Updated by pospelov 12 months ago

The problem is in FitObjectiveBuilder.cpp, line 46.

We have to check type of algorithm,
LMA and Fumili works only with evaluate_residuals method.

All other workw with both, evaluate, and evaluate_residuals

#3 Updated by pospelov 11 months ago

  • Assignee set to pospelov

#4 Updated by pospelov 11 months ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF