Bug #2245

Crash when running simulation with missing instrument

Added by juan 11 months ago. Updated 11 months ago.

Status:ResolvedStart date:06 Dec 2018
Priority:NormalDue date:
Assignee:dmitry% Done:

0%

Category:-
Target version:Sprint 39

Description

To reproduce:

1. Open Bornagain.
2. Remove all instruments from the instrument view.
3. Define some simulation in the Sample view (e.g. "Cylinder and Prisms" from the Standard Samples).
4. Import some 2d data in the Import view (e.g. mydata.int).
5. Change to the Simulation view. Set the fields of "Data selection" section to the values "Select Sample: example01", "Select Real Data: mydata".
6. Click run simulation.... BAM!

See screenshots.
The issue is not present if there is no imported data.

SimulationView.png (74.8 KB) juan, 06 Dec 2018 10:59

ImportView.png (84.7 KB) juan, 06 Dec 2018 10:59

SampleView.png (158 KB) juan, 06 Dec 2018 10:59

InstrumentView.png (40.8 KB) juan, 06 Dec 2018 10:59

mydata.int (215 KB) juan, 06 Dec 2018 11:05

History

#1 Updated by juan 11 months ago

#2 Updated by dmitry 11 months ago

  • Status changed from New to Sprint
  • Assignee set to dmitry
  • Target version set to Sprint 39

#3 Updated by dmitry 11 months ago

  • Status changed from Sprint to Resolved

Also available in: Atom PDF