Bug #2305

Premature deletion of OutputData<double> in python

Added by dmitry 9 months ago. Updated 9 months ago.

Status:RejectedStart date:19 Feb 2019
Priority:NormalDue date:
Assignee:dmitry% Done:

0%

Category:-
Target version:Sprint 40

Description

The following line will cause SEGFAULT:

```
axis = result.data().getAxis(0).getBinCenters()
```

Here result is SimulationResult object.
It is caused by premature deletion of OutputData<double> object returned by data() method in python.
A minor, but irritating issue

History

#1 Updated by dmitry 9 months ago

  • Assignee set to dmitry

#2 Updated by dmitry 9 months ago

  • Status changed from Sprint to Rejected

#3 Updated by dmitry 9 months ago

A simpler method SimulationResult::axis was implemented to alleviate the necessity to use such constructs.

Also available in: Atom PDF