Feature #2317

GUI: relax extension constraints for 2D data import

Added by ganeva over 1 year ago. Updated over 1 year ago.

Status:RejectedStart date:05 Mar 2019
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:-

Description

GUI allows for importing data matrix from text files with .txt extension. However, some MLZ instruments save this matrix in the text files with other extensions. For example, KWS3 saves matrix in the text files with extension .det.

For an average GUI user it is quite some work to rename several tens of files to be able to load them in GUI.

I think, this constraint should be relaxed. We should not determine the file type by extension.


Related issues

Related to BornAgain - Feature #1817: GUI: provide an easy way of importing instrument definitions and real data into the GUI Backlog 12 Jun 2017
Related to BornAgain - Feature #1805: Code dependencies: investigate usage of Python packages from C++ (fabio, periodictable) Long Term Idea 11 May 2017

History

#1 Updated by ganeva over 1 year ago

  • Related to Feature #1817: GUI: provide an easy way of importing instrument definitions and real data into the GUI added

#2 Updated by ganeva over 1 year ago

  • Related to Feature #1805: Code dependencies: investigate usage of Python packages from C++ (fabio, periodictable) added

#3 Updated by pospelov over 1 year ago

  • Status changed from New to Rejected

Duplicate of #2311.
Text copied there.

Also available in: Atom PDF