Bug #2328

Crashing during GISAS fitting

Added by dmitry 8 months ago. Updated 6 months ago.

Status:RejectedStart date:19 Mar 2019
Priority:NormalDue date:
Assignee:-% Done:

0%

Category:-
Target version:Sprint 41

Description

To reproduce:

1. choose default GISAS instrument
2. set "Cylinders and Prisms" standard sample
3. load attached tiff as the experimental data.
4. run simulation
5. choose Genetic as fitting engine, with specifying 100 iterations and 100 popsize.
6. choose cylinder radius as fitting parameter.
7. Run fitting

At approximately 4000th-5000th iteration either computer freezes or BornAgain crashes.

TestGISAS.tif (39.3 KB) dmitry, 28 Mar 2019 13:05

History

#1 Updated by dmitry 8 months ago

  • Description updated (diff)

#2 Updated by dmitry 8 months ago

  • File deleted (TestGISAS.tif)

#3 Updated by dmitry 8 months ago

#4 Updated by dmitry 6 months ago

  • Status changed from Sprint to Rejected

Bug was reproduced on one computer only because of hardware malfunctioning

Also available in: Atom PDF