Bug #2380

Simulation failure for particles crossing interface

Added by ganeva 3 months ago. Updated 3 months ago.

Status:RejectedStart date:25 Jul 2019
Priority:NormalDue date:
Assignee:herck% Done:

0%

Category:-
Target version:-

Description

I am not sure whether it is a bug or a feature. To reproduce the issue, create buried particles with broad size distribution. The broader is the size distribution, the more weird will be the SLD profile.
GISAS simulation will fail with the message:

terminate called after throwing an instance of 'Exceptions::RuntimeErrorException'
  what():  Error in runComputations: At least one simulation thread has terminated unexpectedly.
Messages: DecouplingApproximationStrategy::scalarCalculation() -> Error! Amplitude is NaN -

Figure_4.png - SLD profiles for various sigma (22 KB) ganeva, 25 Jul 2019 14:38

bug2.py Magnifier - Script to reproduce the issue (1.82 KB) ganeva, 25 Jul 2019 14:39

History

#1 Updated by herck 3 months ago

  • Status changed from New to Rejected
  • Assignee set to herck

This is not a bug. Log-normal distributions with sigma values as used in the script are extremely broad. For example, for sigma=10, the mean value is 5e21 times bigger than the median!

Also available in: Atom PDF