Feature #787

Feature #418: === Configuration & Build ===

Revise build instruction for Mac

Added by pospelov about 6 years ago. Updated over 5 years ago.

Status:ArchivedStart date:28 Aug 2014
Priority:NormalDue date:
Assignee:pospelov% Done:

0%

Category:-
Target version:Sprint 25

Description

According our build instruction under Mac, user have to install third party libraries into /opt/local using macport, and then build BornAgain against /opt/local.

The problem is arising when user tries to run BornAgain using system python instead of one in /opt/local.
There is typical error warning, something about "PyThreads error bla-bla" because of mismatch between shared python library and interpretor used.

Possible solution:
  • Try to elaborate new installation instruction which will imply usage of system Python.

But it will be more difficult to install missed modules, for example, matplotlib to the system Python

or

  • Add warning to the installation instruction that Python from /opt/local should be used for the analysis
  • Forget about the problem, hoping that our future DMG installer will take care about everything using some voodoo magic

History

#1 Updated by pospelov almost 6 years ago

  • Description updated (diff)
  • Status changed from Backlog to Sprint
  • Assignee set to pospelov
  • Priority changed from Low to Normal
  • Target version set to Sprint 25

#2 Updated by pospelov almost 6 years ago

  • Status changed from Sprint to Resolved

#3 Updated by herck over 5 years ago

  • Status changed from Resolved to Archived

Also available in: Atom PDF